
ENHANCEMENTS

Geology
Connect multiple databases

You can now view, connect, and work on multiple databases 
in the new Databases pane.

View report for multiple databases that are connected

When you are connected to multiple databases and use the 
DATABASE SUMMARY function, the summary report output 
file now displays the database tables summary for all the 
connected databases.

Auto adjust domain codes

When you run the ASSIGN MULTIPLE DOMAINS function, 
you can now use the Auto adjust check box to reflect the 
«depth from» and «depth to» values of the domain table in 
the comparison table according to the tolerance value you 
specified.

Report overlapped intersections between multiple solids

When you run the ASSIGN MULTIPLE DOMAINS function, 
you can now use the Save overlap check box to report the 
overlapped intersections of drill holes between two solids, in 
the field that you specify in the Domain overlap field.

ASSIGN MULTIPLE DOMAINS uses the new constraint 
engine

Now, you can use the new constrain engine when using the 
ASSIGN MULTIPLE DOMAINS function.

Use new function to highlight points not available in 
drillhole intervals

You can now use the COMMON POINT HIGHLIGHT (CPH) 
function to highlight points, in a digitized string file (in the 
active layer), that are not located in drillhole intervals in an 
active database, according to the tolerance value you specify.

COMMON POINT ADJUST (CPA) adjust the points that are 
not coincident with drillhole intervals

COMMON POINT ADJUST (CPA) adjust the points in the 
digitized string loaded in active layer, that are not coincident 
with the drillhole intervals of active database, within some 
given tolerance limit.

Combine the active database constraints with AND and OR 
operators

You can now combine the constraints in an expression, for 
an active database, with the AND and OR operators.

Save constraint file in .xdbc format

You can now save a database constraint file in the new .xdbc 
file format and display the drillhole data with the applied 
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constraint. The fields in the new .xdbc file are stored in an 
.xml format which can be viewed in a text editor.

Select drillholes spatially with a new database constraint 
type

Now, you can select geological database drillholes spatially 
by using the new constraint type 3DM

on the Define query constraints form.

Select drillholes spatially with new TABLE database 
constraint type

Now, you can select geological database drill holes by 
using the new constraint type TABLE on the Define query 
constraints form. This is used to constrain drill holes with 
all tables in geological database which contains hole_id as 
a field name.

Select drillholes spatially for DTM files with new database 
constraints

When you constrain database of type DTM on the Define 
query constraints form, you can now select the check 
boxes Above and Keep drillholes partially in the constraint 
to display the geological database drill holes spatially. 
Selecting or clearing the Above check box displays drill 
holes that are above or below the surface respectively, for 
specific trisolations. Selecting Keep drillholes partially in 
the constraint displays drill holes which are intersecting the 
trisolation. You can access the form by running the function 
CONSTRAIN DRILLHOLES.

Select drillholes spatially with a new database constraint 
type

Now, you can select geological database drill holes spatially 
by using the new constraint type STRING on the Define 
query constraints form. This is largely used to constrain drill 
holes that are completely or partially within a horizontal 
polygonal boundary such as a pit or lease boundary.

Certain functions support multiple database processing

GRAPHICS EXTRACT PLANS FOR PLOT and GRAPHICS 
EXTRACT SECTIONS FOR PLOT functions support the 
processing of multiple databases. The output file contains 
information for function outcome on all the connected 
database sessions. The functions populate the combination 
of all the:

•	 tables present in multiple databases

•	 fields present in a selected table across the multiple 
databases.



Use GRAPHICS DRILL HOLE LAYOUT for multiple databases

When you use the GRAPHICS DRILLHOLE LAYOUT function, 
you can view the data that is extracted (for all the databases) 
from the collar table, in the Graphics window.

Activate a database

When you connect to multiple databases, you can now use 
the DB SELECT ACTIVE (DBSA) function and then choose a 
database from a list, to activate the database. You can also 
use the following path to activate a database: Database > 
Database > Select active.

Activate a block model

When you load multiple block models, you can now use the 
new BM SELECT ACTIVE (BMS) function and then choose a 
block model from a list, to activate the block model. You can 
also use the following path to activate a block model: Block 
model > Block model > Select active.

Use .dbc file to apply database constraint

You can now constraint a geological drill hole database with 
a .dbc file by clicking Load and browsing a file for TABLE 
constraint type in the Define query constraints form.

Apply database constraint with .xdbc extension

You can add a constraint file with new extension .xdbc to 
a database and display the drillhole data with the applied 
constraint. To add constraint, click Database > Display > Add 
new constraint.

New command to edit database constraints file

You can now use a new command EDIT DB CONSTRAINTS to 
edit the database constraints files of format .xdbc.

Display drillholes spatially along the X and Y axis

To constrain geological database drill holes spatially, you can 
now constraint a file along the X, Y, and Z axis when STRING 
is the Constraint type on the Database query constraints 
form. To access the form, run the CONSTRAINT DRILLHOLES 
function.

Scl database extension commands to set and get an active 
database

You can activate and get the active database name using the 
SclSetActiveDatabase and SclGetActiveDatabase commands, 
respectively.

Applications
Save .sdm files in specific bookmarks

You can save a .sdm document file in a specific bookmark 
folder by clicking the Assign bookmark folders icon on the 
Save to 3DEXPERIENCE form and then selecting a specific 
folder.

Open multiple files in single layer and clear MySession list

You can now open multiple files from MySession in a single 
layer in the Layer Manager. To perform the operation, drag 
and drop a single file to the Graphics window and then for 
next files drag and drop while pressing the CTRL key. The 
multiple files appear in a single layer. Also, when you click 
Reset graphics, the MySession file list is cleared.

Open EC Document in Surpac from 3DDashboard in browser

You can now open an EC document in an existing or 
new Surpac session from the Bookmark Editor app in the 
3DDashboard open in a separate browser.

Save EC documents to the 3DEXPERIENCE platform

You can now save an EC document whose file format is 
.mdl, .con, .ddb, .sdb, or .grd to the 3DEXPERIENCE server 

by clicking Save Active Window from the action bar in 
MySession and then selecting specific bookmarks using the 
Assign bookmark folders icon.

View updated files in MySession

The specific block models appear in MySession when you:

•	 create a new block model (with or without constraints) 
using regular functions

•	 drop a block model (with or without constraints) from 
the Navigator in the Graphics window.

Also, you can save a block model in the 3DEXPERIENCE 
platform by clicking Save Active Window from the action 
bar in MySession. You can remove a block model from 
MySession by closing the block model. After the file is saved 
on the 3DEXPERIENCE platform, you can right-click the file 
in MySession and view Maturity and Properties.

View updated status for locked and unlocked files in 
MySession

When you upload a file on the 3DEXPERIENCE platform 
from MySession and you refresh MySession, you can now 
hover over the Status column of a file and view tooltip: Not 
locked, Locked by me, and Locked by other user. The tooltips 
indicate the status of a file.

Java upgrade

Java has been upgraded to AdoptOpen version 11.

Replace content of the open file

When using the 3DEXPERIENCE PLM Services panel, you can 
now replace the open file content with any other file content 
by selecting Tools > Replace content in the action bar and 
then selecting a part to replace the selected part.

3DEXPERIENCE Collaboration modes improvement

The collaboration mode enables Surpac to operate with the 
3DEXPERIENCE platform in the following ways:

•	 Model-based collaboration mode provides a 
3DEXPERIENCE Unified Product Structure integration 
through the PLM Collaboration Services embedded 
panel in Surpac. This requires a Collaborative Design for 
Surpac Role license.

•	 Document-based collaboration mode provides access 
to former file persistency and management capacity in 
3DSpace through Enterprise Collaboration panel.

To set the 3DEXPERIENCE collaboration mode, click 
Customise > Default preferences and in the Settings form 
click Applications > 3DEXPERIENCE. The default option in 
the Collaboration mode list is Model based.

New button to browse files from the 3DEXPERIENCE 
platform

When using the 3DEXPERIENCE PLM Services panel, you 
can now view the Open from 3DEXPERIENCE button in 
various forms. You can use the button to browse files 
in the 3D EXPERIENCE platform and open the files in the 
Graphics window. The Open from 3DEXPERIENCE button 
is available in the forms of the BLOCK MODEL OPEN, DHL 
DATABASE DEFINITION, SURVEY DATABASE DEFINITION, 
BLAST OPEN DATABASE, VARIOGRAM MODELLING, DRILL 
HOLES, SELECT GRID, BM MAKE CONSTRAINT, MACRO 
PLAYBACK, and AUTOPLOT functions.

View error message when using incorrect function for a 
collaboration mode

As accessibility and management of Surpac files have 
some difference in between model-based and document-
based collaboration modes, some commands or macros 
managing Surpac files might remain specific to one of those 



modes. When the collaboration mode in the Settings form 
( Customize > Default preferences) is Model based and you 
run a document-based function, an error message appears 
in the Message window “Command {0} unavailable for the 
“Model Based” collaboration mode.” Similarly when the 
collaboration mode in the Settings form (Customize > Default 
preferences) is Document based and you run a model-
based function, an error message appears in the Message 
window “Command {0} unavailable for the “Document 
based” collaboration mode.”

Customize layer name for model-based collaboration

You can now customize the name of the layers in the Layer 
Manager by editing the Customize display field in the Settings 
form (Default preferences > Applications > 3DEXPERIENCE), 
for the files you open from the 3DEXPERIENCE Collaborative 
Space.

Cache implementation for EC documents

A cache is now maintained when you open an enterprise 
collaboration document in the 3DEXPERIENCE PLM Services 
panel. This prevents recurring downloads when you reopen 
the file.

Connect to multiple databases on the 3DEXPERIENCE 
platform

You can now view multiple database entries in MySession 
when you open multiple databases from the 3DEXPERIENCE 
platform using the Select database form. When you select 
File > Close and then select a geological or survey database, 
the entries for the specific databases are now removed 
correctly, one by one, from MySession. You can access the 
Select database form using the DHL DATABASE DEFINITION 
(DHLDBDEF) function.

View file opening options in the Tools tab

In MySession, when you click Tools > Options, you can view 
two options in the Documents and 3DParts list (Drag and 
drop behavior section): Open and Open for Exclusive Edit. 
Clicking Open opens the file without locking content and 
Open for Exclusive Edit opens the file with content locked for 
concurrent users modification.

Log in and log out using the 3DEXPERIENCE icon

When the collaboration mode is model based, you can log in 
and log out of the 3DEXPERIENCE PLM Services panel using 
the Log in/Log out of 3DEXPERIENCE icon available in the 
File toolbar.

Upload geological and survey database to the 
3DEXPERIENCE platform

The specific geology and survey database entries appear in 
MySession when you:

•	 drop a geology (.ddb) or survey (.sdb) database file from 
the Navigator into Graphics

•	 open a database from Database > Database > Open/
New

Also, you can upload a geology or survey database to the 
3DEXPERIENCE platform by selecting Save Active Window in 
the action bar, then Assign bookmark folders on the Save to 
3DEXPERIENCE form and then selecting a bookmark folder.

Upload new grid file to the 3DEXPERIENCE folder

When you create a grid file (.grd) (File tools > Grid tools > 
Define new grid), the new file appears in the MySession 
widget. You can upload the .grd file to the 3DEXPERIENCE 
platform by selecting Save active window icon in the action 
bar, Assign bookmark folders on the Save to 3DEXPERIENCE 
form, and then selecting a bookmark folder.

Tools
Rename description field labels for specific functions

You can rename description field labels for an input file using 
the following three new functions:

•	 EDIT STRING DESCRIPTION LABELS

•	 EDIT STRING RANGE DESCRIPTION LABELS

•	 EDIT DESCRIPTION LABELS

Rename description field labels using SCL commands

You can rename description field labels using the following 
SCL commands:

•	 SclSetDescriptionFieldLabelByName

•	 SclSetDescriptionFieldLabelByIndex

For the above commands, you can update the description field 
labels using index or name of a field.

Edit description field label

When you run the IMPORT FROM TEXT function, you can 
now edit the description field labels in the Fields form and 
generate .sdm files from any file input. You can view the 
updated description field names in the Properties pane when 
you drop the output file in the Graphics window.

View description field labels in the Desc Labels list

For an .sdm file input, you can view the complete description 
field labels instead of the d-fields (d1,d2, and so on) in the 
Desc Labels list (click the Load button) in the forms that 
appear after using the following functions:

•	 • BM FILL NEAR NEIGHBOUR

•	 • BM FILL OK

•	 • BM FILL SK

•	 • BM ASSIGN FROM STRING

View description field labels with database composite 
functions 

When using the database composite functions COMPOSITE 
DOWNHOLE, COMPOSITE BY GRADE, and COMPOSITE BY 
GEOLOGY you can now view the complete description field 
labels in the .sdm output, instead of the d-fields (d1, d2, and 
so on).

Database extract functions export the description field 
names

You can now view the complete description field labels instead 
of the d-fields (d1, d2, and so on) when exporting a file in .sdm 
format after using the following database extract functions:

•	 DRILL HOLE LAYOUT (DHL)

•	 ZONE THICKNESS (ZT)

View complete description field names for database 
discrete functions

You can now view the complete description field labels instead 
of the d-fields (d1, d2, and so on) for database discrete sample 
functions. For example, if d1 represents samp_id, you can 
view samp_id in the Properties pane instead of d1.

Block model report functions export the real attribute 
names to .sdm files

You can now view the real block model attribute names 
instead of the d-fields (d1, d2, and so on) in an .sdm format 
output file after using the following functions:

•	 BM BLOCK REPORT (BMBR)

•	 BM STRING REPORT (BMSR)



View description field names for .sdm files

You can now view the complete description field labels instead 
of the d-fields (d1, d2, and so on), when exporting a file in 
.sdm format after using the following functions:

•	 EXTRACT PLANS FOR PLOT

•	 EXTRACT SECTIONS FOR PLOT

•	 EXTRACT PLANS FOR CALC

• EXTRACT SECTIONS FOR CALC

Database export functions export the real attribute names 
to .sdm files

You can now view the real database attribute names instead 
of the d-fields (d1, d2, d3, and so on) in

an .sdm format output file after using the following functions:

•	 EXTRACT SAMPLE DATA

•	 EXTRACT SAMPLE DATA WITHIN GEOLOGY

•	 ORE TO WASTE RATIO

View complete description field names for database 
composite functions

You can now view the complete description field labels instead 
of the d-fields(d1, d2, and so on) for database composite 
functions. For example, if d1 represents Hole ID, you can now 
view Hole ID in the Properties pane instead of d1.

ISSUES FIXED
Geology
Surpac is able to load point cloud files with cyrillic 
characters

Surpac is able to open and render point cloud files whose file 
paths contain cyrillic characters.

Connect to geology and survey database concurrently

You can now connect to a geology and survey database 
concurrently.

Clear button on the Define query constraint works correctly

When you have not defined any field on the Define query 
constraints form and click the Clear button, Surpac no longer 
stops responding.

View all database table and Hole IDs in Structural suite 
forms

You can now view tables and hole IDs respectively, from all 
the connected databases, in the specific forms when you click:

•	 Database > Structural suite > Data visualizer menu and 
then Data source tab

•	 Database > Structural suite > Locate drillhole

Connect multiple databases

You can now connect to multiple databases when you open a 
database file from the:

•	 Navigator panel

•	 File > Open > Geological database menu

•	 File > Open > Survey database menu

ZOOM ALL function works correctly for multiple connected 
databases

For multiple databases connected, when you run the ZOOM 
ALL function, the drillholes from all the connected databases 
are now displayed correctly in the Graphics window.

View description field labels correctly

You can now view each description field label correctly 
in a single line in the Description labels list (Data source 
specifications form). Previously, the label was splitting into 
multiple rows.

Zero width intersections are omitted

While assigning multiple domains, intersections of zero width 
will be omitted from the process and the report.

Surpac successfully creates 3DM result files

When you use a file intersection function and one of the 
3DM files is located in a non work directory or in a sub folder, 
Surpac no longer displays an error message and creates a 
3DM result file successfully.

Miscellaneous
View project file name in message window for SSO form

You can now view the project file name as a warning message, 
in the Message window, when the project name you defined 
in the Stope shape optimization tool form is invalid.

Tools
Improvements in the IMAGE DRAPE function

When you use the IMAGE DRAPE function and select a 
registration file, you can now move the registration markers 
to new locations without the markers disappearing. You can 
also view the correct values in the new Z Data column on the 
Review registration point coordinates form.

Use an SCL command to create an .sdm file output

You can now use the SCL command SclSwaSaveDtmFile to 
create a .sdm file output in a non-work directory or a sub-
folder when the input file is logical.

Export markers to 3D PDF

You can now export markers present in a string file to 3D PDF 
when using the EXPORT TO 3D PDF function.

Improvement in the IMPORT FROM TEXT function

When you run the IMPORT FROM TEXT function, you can 
now view the column headers Description label and Position 
on the Fields form.

View macro recording on the icon

The Start/end recording an SCL script icon now flashes when 
you start recording a macro.

Improved error management in the DTM VOLUMES function

An access violation message no longer appears, when you 
now run the DTM VOLUMES function and the object ID and 
trisolation ID for the first and second DTMs i.e. default Object 
1 & Trisolation 1, does not exist in the specified data.

Applications
Surpac uses the latest CATPolyhedral library R425Rel

Surpac has been updated to use the latest CATPolyhedral 
library R425Rel enabling the following

functionality (appearing in previous releases) when you open 
a Point Cloud file in the Graphics

window:

•	 creation of a DSCache and a matching .dspc file

•	 display of the file specific layer in the Layer Manager

Also, a new functionality enabling the removal of duplicate 
points is available.
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Our 3DEXPERIENCE® platform powers our brand applications, serving 11 industries, and provides 
a rich portfolio of industry solution experiences. 
Dassault Systèmes, the 3DEXPERIENCE® Company, is a catalyst for human progress. We provide business and people with collaborative virtual 
environments to imagine sustainable innovations. By creating ‘virtual experience twins’ of the real world with our 3DEXPERIENCE platform and 
applications, our customers push the boundaries of innovation, learning and production. ºDassault Systèmes’ 20,000 employees are bringing value to more 
than 270,000 customers of all sizes, in all industries, in more than 140 countries. For more information, visit www.3ds.com

Configuration
View ID range for the CLASSIFY STRINGS (CLASS) function 
output

For the CLASSIFY STRINGS (CLASS) function, when you 
enter the file name, ID range, and file extension in the output 
location path in a macro script, the Message window now 
displays the output file name appended with the ID range.

Hoops upgrade

The third-party software, Hoops, has been upgraded to 26.21.


